Auteur Sujet: Rétro-signalisation S88 avec Arduino  (Lu 3151 fois)

pierrepv

  • Newbie
  • *
  • Messages: 40
    • Voir le profil
Rétro-signalisation S88 avec Arduino
« le: novembre 01, 2017, 08:38:09 pm »
   Bonjour,

J'ai câblé une rétro-signalisation de mon réseau en suivant les instruction du projet "Rétrosignalisation avec ARDUINO" du site Locoduino.

J'utilise un MEGA2560.
J'ai fabriqué mes détecteurs de consommation, j'ai relié le tout à mon "Intellibox1", elle-même relié à un ordinateur sous XP équipé de RRTC.

Tout fonctionne bien avec les 16 premiers cantons, sur l'Intellibox, un rectangle noir s'allume bien lorsqu'un train est détecté.

Par contre à partir du 17° canton rétro-signalé, plus rien n'est détecté.

Pourtant mon signal passe bien de 0 à 5V à la sortie de mon détecteur relié à la broche 22 de l'Arduino.

J'ai déclaré 2 modules dans l'Intellibox, et j'affiche bien le 2° module, mais aucun rectangle noir n'apparait signalant l'occupation.

Que peut-il se passer?
Quelqu'un a-t-il déjà eu ce problème?

  Cordialement
R�seau en N - 70m de voie - R�trosignalisation sur Arduino Mega2560 - RRTC Siver sous Windows10

pierrepv

  • Newbie
  • *
  • Messages: 40
    • Voir le profil
Re : Rétro-signalisation S88 avec Arduino
« Réponse #1 le: novembre 02, 2017, 04:20:17 pm »
   Bonjour,

J'ajoute quelques précisions à mon post précédent:

- j'utilise très exactement le schéma de détection donné dans le projet Locoduino": La Rétrosignalisation sur Arduino.

- j'utilise un Arduino Méga 2560 avec le programme et la bibliothèque donné dans le projet.

- j'ai relié les broches 4 à 19 de l'Arduino à mes détecteurs et tout marche, sur l'Intellibox, un rectangle noir s'allume quand on affiche "Mode Monitor S88.


Le problème réside quand je veux connecter un 17° détecteur d'occupation.

Je paramètre 2 modules dans l'Intellibox, et j'affiche le module 2, mais là rien, aucun carré noir ne s'allume sur l'écran.

Si je passe la broche 22 à GND, ce n'est pas mieux.


Y aurait-il une modification à faire dans le programme pour gérer l'Intellibox, quelqu'un a-t-il tester plus de 16 détecteurs.

C'est bizarre que celà se produise justement au premier detecteur du 2° module... >:(


    Cordialement

R�seau en N - 70m de voie - R�trosignalisation sur Arduino Mega2560 - RRTC Siver sous Windows10

pierrepv

  • Newbie
  • *
  • Messages: 40
    • Voir le profil
Re : Rétro-signalisation S88 avec Arduino
« Réponse #2 le: novembre 02, 2017, 04:52:53 pm »
     Bonjour,

J'ai trouvé,

- dans le sketch du S88, il faut penser en début de programme à mettre 2 à la place de 1 dans le nombre de modules, sinon le signal S88 n'est généré que pour les 16 premiers détecteurs.

C'est ici:

#include <MEGA_S88.h> // librairie S88 pour le MEGA
void setup() {
  // put your setup code here, to run once:
  S88_Setup(1);       METTRE 2 OU 3 OU 4 SELON LE NOMBRE DE MODULES UTILISES.
}

void loop() {
  // put your main code here, to run repeatedly:
  S88_Loop();
}


Ca peut servir à d'autres....

   Cordialement
R�seau en N - 70m de voie - R�trosignalisation sur Arduino Mega2560 - RRTC Siver sous Windows10

Thierry

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 501
    • Voir le profil
Re : Rétro-signalisation S88 avec Arduino
« Réponse #3 le: novembre 02, 2017, 05:57:10 pm »
Bonjour, bienvenue, et merci pour votre retour d'expérience.

C'est toujours utile parce que l'on apprend de ses erreurs, et que si vous n'avez pas trouvé du premier coup, c'est peut être que la fonction a été mal documentée dans le code, ou mal expliquée dans l'article... Bon courage pour la suite !