Auteur Sujet: Bonjour / Strelok (problème lecture courant de programmation)  (Lu 10720 fois)

strelok

  • Newbie
  • *
  • Messages: 4
    • Voir le profil
Bonjour / Strelok (problème lecture courant de programmation)
« le: février 18, 2019, 09:56:37 pm »
Bonjour à tous,

Je me lance à petits pas dans le monde du DCC en commençant par la digitalisation d'une loco PIKO avec
une centrale DCC++ basée sur un Arduino NANO (code de Gregg E. Berman)

Mais je rencontre quelques difficultés à lire les valeurs programmées et c'est le but de ma venue sur le forum

Aujourd'hui j'ai programmé en F0 F1 les feux que je peux allumer éteindre sur la voie ops


Cdlt
« Modifié: février 22, 2019, 09:07:23 am par strelok »

msport

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 2217
  • HO avec DCC++ en DIY Réseaux très éphémères
    • Voir le profil
Re : Bonjour / Strelok
« Réponse #1 le: février 19, 2019, 06:41:44 pm »
Bienvenue à Locoduino.

un schéma serait plus parlant que la photo, bien utile néanmoins.
Est-ce qu'il s'agit d'un montage perso pour simuler un shield à L298 ?
Avec en prime un MAX471 ?

Qu'est-ce qui marche déjà ?

Mais avant tout, vérifier que le rail d'alimentation ne contient pas un condensateur de déparasitage de 100nF.
Cordialement

strelok

  • Newbie
  • *
  • Messages: 4
    • Voir le profil
Re : Bonjour / Strelok
« Réponse #2 le: février 22, 2019, 08:56:39 am »
Bonjour

Oui ça permet d'éviter le shield moteur arduino
Le module l298n (rouge) est superposé sur une plaque à trou où j'ai monté un inverseur (je l'avais en stock)

Il n'y a ni condensateur ou résistances en série / parallèle des voies

J'ai retiré le filtre (capa / self) moteur pour avoir une connexion directe entre le decodeur et le moteur

Lorsque je le programme j'entends de très légers bips mais le moteur ne tourne pas
Ce qui induit un très faible courant donc quelques millivolts en sortie du montage détecteur de courant

J'ai un scope analogique donc sans mémorisation sur trigger

Lorsque vous programmez vos locos il y a un déplacement franc du moteur ?
« Modifié: février 22, 2019, 09:05:28 am par strelok »

msport

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 2217
  • HO avec DCC++ en DIY Réseaux très éphémères
    • Voir le profil
Re : Bonjour / Strelok (problème lecture courant de programmation)
« Réponse #3 le: février 22, 2019, 01:53:26 pm »
Les locos modernes ne bougent pas, les plus anciennes frémissent.

Vous programmez avec le serial monitor ? Quel est le retour ?

Vu le prix d'un shield moteur à L298, pourquoi passer son temps à réinventer l'eau tiède ?
On a moins de chances d'avoir des faux contacts ou c/c.

Je laisse les selfs et capacité dans les locos (elles restent d'ailleurs sur les locos équipées de prise NEM) sans problème.
La capacité sur les rails d'alimentation analogique typiquement de 100nF, est ~1000 fois supérieure.
Vous êtes vraiment sur qu'il n'y a rien dans votre rail d'alimentation ? Permutez le quand même.
Mais sans schéma, difficile de deviner.
Cordialement

strelok

  • Newbie
  • *
  • Messages: 4
    • Voir le profil
Re : Bonjour / Strelok (problème lecture courant de programmation)
« Réponse #4 le: février 25, 2019, 06:40:40 pm »
J'ai mesuré au scope (math voie a moins voie b) et il y a une sacré non linéarité lors d'une commutation
Je vais acheter un module lmd18200 qui j'espère fera l'affaire

J'ai un trigger de Schmidt 74hc pour inverser le signal afin d'obtenir un différentiel attaquant le l298

msport

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 2217
  • HO avec DCC++ en DIY Réseaux très éphémères
    • Voir le profil
Re : Bonjour / Strelok (problème lecture courant de programmation)
« Réponse #5 le: février 25, 2019, 11:48:12 pm »
Ne perdez pas votre temps :

Montez ce shield sur un UNO (avec Base Station), alimentez en 12V, 2A, ajoutez les deux straps Dupont et utilisez la voie de programmation.

https://www.ebay.fr/itm/Dual-2-Channels-Arduino-L298NH-H-Bridge-Motor-Driver-Shield-Module-Than-L298P/263920400204

https://www.ebay.fr/itm/12V-EU-Power-Adapter-0-5A-500ma-1A-2A-AC-AC-110V-240V-DC-Supply-for-LED-strip/183176717819

http://www.locoduino.org/spip.php?article187 ( voir UNO + ARDUINO MOTOR SHIELD, pour votre problème et pour des tests, pas besoin de séparer les alimentations, restez en 12V )
Cordialement

strelok

  • Newbie
  • *
  • Messages: 4
    • Voir le profil
Re : Bonjour / Strelok (problème lecture courant de programmation)
« Réponse #6 le: mars 23, 2019, 12:49:22 pm »
Re-bonjour messieurs,

Je viens de repasser la loco en analogique via le bloc de diodes et là je me suis rendu compte que le moteur à pris un coup
En effet j'avais envoyé du DCC à la loco analog (!!!) au tout début de mes expérimentations :-\

J'ai donc câblé un autre moteur et j'ai pu relire les valeurs avec processing & DccppController

C'est pour ça que j'arrivais à allumer les feux, mais pas à relire les valeurs!

Si ce message peut servir à quelqu'un


Simon.