Auteur Sujet: l'IDE Arduino dysfonctionne t-il soudainement chez vous ?  (Lu 1102 fois)

simontpellier

  • Full Member
  • ***
  • Messages: 114
    • Voir le profil
l'IDE Arduino dysfonctionne t-il soudainement chez vous ?
« le: juillet 03, 2022, 06:41:20 pm »
Bonjour et SOS...

J'imagine que tout le monde a connu des moments de raz le bol...
là je craque "grave" et ... surprise ! je ne trouve rien ici qui traite de "mon cas" qui ne doit pourtant pas être isolé, ça n'est pas possible !

Voilà
Je suis exceptionnellement resté quelques jours sans éprouver le besoin de retoucher un code ou l'autre... jusque hier. Et là... PLUS RIEN NE COMPILE ! Ni Arduino ni teensy... et ça sur mes deux PC...

Je me souviens vaguement d'une mise à jour des cartes Arduino ? ça ne doit pas être ça car un downgrade n'a rien changé
Ainsi qu'une d'une mise à jour W10...
personne n'a eu de soucis récemment ??

Sur Arduino ça c'est réglé assez facilement... j'avoue que je ne saurais plus dire comment... il me reste tout de même l'étonnement de plus plus pouvoir faire fonctionner un vieux code blink de test qui contenait "byte LED_BUILTIN = 13;" et ça marchait, j'en suis certain !
Or plus moyen de compiler, maintenant seul #define LED_BUILTIN 13 passe la compilation (???). Pas grave.

Sauf que je suis maintenant principalement sur Teensy, 3.5 et 3.2 et là c'est bien pire :
- téléchargement et réinstallation de TeensyduinoInstall.exe... ouf ça marche !
... aïe ("M") une seule fois ! on peut télécharger un code mais la seconde fois produit le message "Une erreur est survenue lors du transfert du croquis - Could not run teensy_reboot.exe (CreateProcess error)"
- nouvelle installation ? Eh non.. refus "unable to write file "harware/tools/teensy_reboot.exe"
- redémarrage du PC et nouvelle tentative... ça marche (une fois. Etc etc)
- enfin ça marche... à peu près ! le code se charge et tourne mais le port USB est "offline"... pas de Serial ! "Unable to run teensy_serialmon"

Bien sûr il y a le forum Teensy... mais le problème semble plus général et peut-être y a-il une piste à laquelle je n'ai pas pensée ? (et puis ici on speak français !)
Ça me remotiverait ! car là j'ai des envies de plutôt de me mettre au tricot !
« Modifié: juillet 03, 2022, 08:14:49 pm par simontpellier »

Dominique

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 2653
  • 100% Arduino et N
    • Voir le profil
Re : problème de mise en œuvre sur Teensy
« Réponse #1 le: juillet 03, 2022, 07:40:45 pm »
Bonjour Simontpelier,

Le titre de cette contribution m’a fait sursauté et je ne vois pas de quel projet il s’agit, si c’est du modélisme ferroviaire. Donc, en français, il serait mieux de donner un titre plus adéquat et de préciser le problème, voire le programme concerné.

J’ai aussi moi-même un Teensy 3.6 dans les cartons depuis un bon moment. Je vais tester dès que possible sur Mac seulement et cela demande un peu de patience ..

Cordialement,
Dominique

simontpellier

  • Full Member
  • ***
  • Messages: 114
    • Voir le profil
Re : l'IDE Arduino dysfonctionne t-il soudainement chez vous ?
« Réponse #2 le: juillet 03, 2022, 08:08:01 pm »
Bonjour Dominique...

Le projet ? ça peut être du modélisme ferroviaire en pleine voie de tout mes posts ici... ou du tricot selon l'aide que je recevrai (j'espère). Mais pour le tricot je changerai bien sûr de forum !

Quant-au problème...
je reformule : un "truc" a changé dans la configuration de l'IDE Arduino et/ou, plus vraisemblablement de l'environnement Windows et je ne sais pas où chercher.
Je me suis donc mis en mode "débutant" incapable de configurer son Arduino.
Car peu importe la nature des codes (mais promis c'est du "ferroviaire"), le constat tel que je l'ai détaillé est indépendant du code et a concerné autant Teensy que AVR (moins gravement ces derniers)

j'ai voulu un titre accrocheur... mais d'accord pour le "modérer"
« Modifié: juillet 03, 2022, 10:08:22 pm par Dominique »

Dominique

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 2653
  • 100% Arduino et N
    • Voir le profil
Re : l'IDE Arduino dysfonctionne t-il soudainement chez vous ?
« Réponse #3 le: juillet 03, 2022, 10:17:51 pm »
D’emblée à la question « l'IDE Arduino dysfonctionne t-il soudainement chez vous ? », je répond NON !

Que ce soit de l’AVR, de l’ESP, du Due, Non !
Pour le Teensy je vais essayer mais pas tout de suite.
Pour W10 je ne crois pas, bien que je sois inconditionnellement sur Mac.

Je vous conseille de vérifier votre pc : est-ce que d’autres logiciels dysfonctionnels également ?
Mais sur ce sujet je ne peut vous aider plus loin (mon Mac va bien).
D’autres utilisateurs sur pc prendront la relève…
Cordialement,
Dominique

msport

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 1935
  • HO avec DCC++ en DIY Réseaux très éphémères
    • Voir le profil
Re : l'IDE Arduino dysfonctionne t-il soudainement chez vous ?
« Réponse #4 le: juillet 03, 2022, 11:01:45 pm »
Bonsoir,

pas de souci de mon coté non plus.

donc dans ces grands moment de solitude, il faut demander à l'IDE de faciliter le dialogue en :
allant dans Fichier->Préférences et cochant les 2 cases après « Afficher les résultats détaillés pendant »

Et puis ne rien nous cacher de ce qu'il a dit. En général, il est compréhensif ...

Si ça coince, on peut tenter de lancer l'IDE en tant qu'administrateur. (et de vérifier que l'utilisateur a tous les droits sur les fichiers/répertoires utilisés)
« Modifié: juillet 03, 2022, 11:06:59 pm par msport »
Cordialement

Jean-Luc

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 1655
    • Voir le profil
Re : l'IDE Arduino dysfonctionne t-il soudainement chez vous ?
« Réponse #5 le: juillet 04, 2022, 02:13:29 pm »
Pour le reste je ne sais pas mais concernant ceci :

Sur Arduino ça c'est réglé assez facilement... j'avoue que je ne saurais plus dire comment... il me reste tout de même l'étonnement de plus plus pouvoir faire fonctionner un vieux code blink de test qui contenait "byte LED_BUILTIN = 13;" et ça marchait, j'en suis certain !
Or plus moyen de compiler, maintenant seul #define LED_BUILTIN 13 passe la compilation (???). Pas grave.

Avec quelle erreur ?

Revenons au problème.

À un moment, le symbole LED_BUILTIN a été ajouté (je ne sais plus quand) car les cartes n'avaient pas toutes la LED sur la broche 13 (les ESP32 notamment). Évidemment sur certains board packages, ça a été via un #define et sur d'autres via un const byte.

Si l'ajout a été via un const byte alors mettre une const byte qui définit le même symbole est une erreur. Si l'ajout a été fait par un #define alors définir soi même LED_BUILTIN via un const byte (le préprocesseur remplacera le LED_BUILTIN par sa valeur et on aura qq chose comme const byte 13 = 13; ce qui n'est évidemment pas permis) ou un #define est une erreur.

Dans ton cas, c'est clairement un const byte qui sert à définir LED_BUILTIN dans le board package.

Conclusion, les vieux sketchs doivent être entretenus.
Cordialement

simontpellier

  • Full Member
  • ***
  • Messages: 114
    • Voir le profil
Re : l'IDE Arduino dysfonctionne t-il soudainement chez vous ?
« Réponse #6 le: juillet 04, 2022, 07:24:21 pm »
Merci... !
merci notamment à msport.. le grand moment de solitude hihi c'était exactement ça ! et j'ai remarqué que vous êtes bien souvent là sur le forum pour adoucir de tels moments de façon positive !
merci aussi à Jean-Luc pour son explication rationnelle du phénomène blink. C'est au moins un point réglé... mais ça n'est hélas qu'un point de détail. Le phénomène que je rencontre est bien plus exaspérant. Et ça n'est pas lié au PC puisqu'il affecte mes deux PC de la même façon, il y a donc un mode commun quelque part. Or rétrograder vers la dernière mise à jour n'est plus possible, je viens de regarder, car elle a plus de 10j... pourtant j'y croyais.

J'imagine que d'une façon ou d'une autre le problème sera réglé, encore une fois... mais que de temps et d'énergie mentale perdue (je crains qu'un jour le sursaut nécessaire pour "entretenir" ne devienne une aliénation insupportable. Dommage pour le plaisir de la bidouille et de la création... )
Je reviendrai dire comment. Ce qui me surprend et m'embête beaucoup est de m'apercevoir que je serais le patient zéro ? (nul à ce point ??)

simontpellier

  • Full Member
  • ***
  • Messages: 114
    • Voir le profil
Re : l'IDE Arduino dysfonctionne t-il soudainement chez vous ?
« Réponse #7 le: juillet 16, 2022, 03:55:55 pm »
trouvé !


msport

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 1935
  • HO avec DCC++ en DIY Réseaux très éphémères
    • Voir le profil
Re : Re : l'IDE Arduino dysfonctionne t-il soudainement chez vous ?
« Réponse #8 le: juillet 16, 2022, 04:28:49 pm »
Retour intéressant !


merci notamment à msport.. le grand moment de solitude hihi c'était exactement ça ! et j'ai remarqué que vous êtes bien souvent là sur le forum pour adoucir de tels moments de façon positive !
De rien, comme le dit Manau : un druide au rendement médiocre mais bénéfique sur le plan subjectif.
Cordialement