Auteur Sujet: problème de téléversement Nano  (Lu 735 fois)

psavArd

  • Newbie
  • *
  • Messages: 4
    • Voir le profil
problème de téléversement Nano
« le: décembre 09, 2020, 09:12:27 pm »
Bonjour,
cela fait plusieurs années que j'utilise des Arduino Nano pour effectuer des petites animations telles que clignotement de Leds aux passages à niveau, commande de barrières et aiguillages à l'aide de servo moteurs, commande d'animations musicales par carte lecteur MP3 ... J'utilise des nano car ils sont faciles à intégrer dans le paysage (petite cabane de voie ...). N'en ayant plus, j'en ai commandé deux fois sur le net, et avec ces nouvelles cartes (sensiblement identiques aux précédentes), je n'arrive plus à téléverser les sketchs ?
IDE version 2:1.0.5 installé sur PI3, liaison par bus USB fonctionne très bien avec cartes Uno et Leonardo. Avec Nano : no sync 10 essais infructueux : pas de téléversement possible.
J'ai mis en doute le bootloader, donc utilisé le procédure Graver la séquence d'initialisation après avoir téléversé le sketch dans Exemples/ArduinoISP, et relié les deux cartes Uno et Nano par bus ISCP, la programmation se passe bien, il y a échanges entre les deux cartes, pas d'erreur sur Led sortie 8 et pas d'erreur dans l'IDE, message : Initialisation Terminée.
Mais toujours pas de téléversement des Nano. Ils fonctionnaient bien, car led 13 clignotante.
Voila quelqu'un peut-il m'aider ?

Dominique

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 2263
  • 100% Arduino et N
    • Voir le profil
Re : problème de téléversement Nano
« Réponse #1 le: décembre 09, 2020, 09:20:23 pm »
Dans le menu Outils, choisissez : ATMega328P (old bootloader)

Les Pro Mini sont équivalents au Nano et encore plus petits. J'en utilise beaucoup.
« Modifié: décembre 09, 2020, 09:22:19 pm par Dominique »
Cordialement.

La qualité des réponses est liée à la qualité des questions. Les Winners, c'est juste des Losers qui s'acharnent..

psavArd

  • Newbie
  • *
  • Messages: 4
    • Voir le profil
Re : problème de téléversement Nano
« Réponse #2 le: décembre 09, 2020, 09:38:25 pm »
Oui, j'avais déjà vu cette option sauf que sur l'IDE 2:1.0.5, je n'ai pas cette option, j'ai :
ArduinoNano/ATMega328 ou ArduinoNano/ATMega 168, donc dépend du processeur utilisé.
Je n'arrive pas à ajouter des options sur les cartes possibles. Je suis d'accord avec vous, le P servait pour les anciennes communications (old BootLoader).
Sur le net je n'arrive pas à trouver quels nano vont pouvoir être téléversés, et quels autres ne le seront pas ...

Dominique

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 2263
  • 100% Arduino et N
    • Voir le profil
Re : problème de téléversement Nano
« Réponse #3 le: décembre 09, 2020, 09:45:30 pm »
Si je comprends bien vous n'utilisez pas l'IDE dernière version (1.8.13)
Qu'est ce que cet IDE 2:1.0.5 ?
Cordialement.

La qualité des réponses est liée à la qualité des questions. Les Winners, c'est juste des Losers qui s'acharnent..

psavArd

  • Newbie
  • *
  • Messages: 4
    • Voir le profil
Re : problème de téléversement Nano
« Réponse #4 le: décembre 09, 2020, 10:24:45 pm »
C'est une des dernières versions que j'ai pu charger suite à mes déboires de téléversement ...
Je vais essayer de recharger 1.8.13 ...

msport

  • Hero Member
  • *****
  • Messages: 1249
  • HO avec DCC++ en DIY Réseaux très éphémères
    • Voir le profil
Re : problème de téléversement Nano
« Réponse #5 le: décembre 09, 2020, 10:37:31 pm »
Google dit : IDE 2:1.0.5 :

I would think that that is Arduino 1.0.5, which is quite a bit older ... (en  2016)

La grande majorité des Nano que j'ai eu utilisent le old bootloader (j'achète les moins chers)

https://magpi.raspberrypi.org/articles/program-arduino-uno-raspberry-pi :
au moins l'IDE 1.8.3 ...


PS : https://www.arduino.cc/en/main/OldSoftwareReleases
« Modifié: décembre 09, 2020, 10:42:34 pm par msport »
Cordialement

psavArd

  • Newbie
  • *
  • Messages: 4
    • Voir le profil
Re : problème de téléversement Nano
« Réponse #6 le: décembre 11, 2020, 02:02:32 pm »
Bonjour tout le monde,
Le problème est résolu.
Effectivement j'utilise une version qui semble être 1.0.5.
Le problème c'est que je n'arrive pas à m'en débarrasser : pas de uninstall.sh.
J'ai téléchargé la version 1.8.13 et bien desarchivé, mais quand je lance install.sh : rien ne se passe. En lisant la doc Arduino, l'explication est qu'on ne peut lancer IDE, car la version de la librairie ne correspond pas. Ce qui semble logique. On ne peut faire cohabiter facilement deux versions différentes de l'IDE.
En regardant un peu plus précisément la doc sur les carte Arduino, il est marqué que la version ATMéga168 est l'ancienne version des processeurs ATMéga328 et ont le même code de compilation : bingo ça fonctionne, le téléversement se passe bien, et j'ai pu télécharger deux types de cartes Nano qui jusqu'alors refusaient d'être téléchargées avec ATMéga328.
Merci pour vos messages d'aide, et à bientôt

simontpellier

  • Jr. Member
  • **
  • Messages: 72
    • Voir le profil
Re : problème de téléversement Nano
« Réponse #7 le: décembre 12, 2020, 09:12:16 pm »
et pour ceux qui achètent des "old bootloader" sciemment... ou pas, à noter qu'on peut garder l'argent du beurre mais quand même avoir le beurre après upgrade des "old":

https://forum-photovoltaique.fr/viewtopic.php?t=42967
https://www.arduino.cc/en/Tutorial/BuiltInExamples/ArduinoISP

magique.