Auteur Sujet: Message d'erreur lors du téléversement avec carte Nano  (Lu 2693 fois)

Papa Schultz

  • Newbie
  • *
  • Messages: 17
    • Voir le profil
Message d'erreur lors du téléversement avec carte Nano
« le: mars 19, 2021, 10:03:45 am »
Bonjour à tous,

Mon problème est le suivant, un message d'erreur apparait lorsque je téléverse un sketch vers ma carte arduino Nano (neuve), et je ne vois pas bien la cause.
Le message est le suivant:

Arduino : 1.8.13 (Windows 10), Carte : "Arduino Nano, ATmega328P"

Le croquis utilise 6784 octets (22%) de l'espace de stockage de programmes. Le maximum est de 30720 octets.

Les variables globales utilisent 184 octets (8%) de mémoire dynamique, ce qui laisse 1864 octets pour les variables locales. Le maximum est de 2048 octets.

avrdude: ser_open(): can't open device "\\.\COM3": Le fichier sp�cifi� est introuvable.


Merci d'avance pour vos réponses.












AmadeusHF

  • Full Member
  • ***
  • Messages: 189
    • Voir le profil
Re : Message d'erreur lors du téléversement avec carte Nano
« Réponse #1 le: mars 19, 2021, 10:24:16 am »
Vous essayez de charger votre arduino via le port série 3 (COM3) de votre ordinateur.

Ce port série n'existe pas .... ce qui veut simplement dire que votre ordinateur affecte un port différent à votre liaison via USB.

Tout ceci fait partie des fondamentaux de l'usage de l'Arduino. Je vous invite à relire les articles de Locoduino relatifs à la prise en main de l'environnement de développement. Les infos s'y trouvent.
Sébastien.
La perfection est un chemin, non un but...

Papa Schultz

  • Newbie
  • *
  • Messages: 17
    • Voir le profil
Re : Message d'erreur lors du téléversement avec carte Nano
« Réponse #2 le: mars 20, 2021, 08:57:17 am »
J'ai relu les fondamentaux, voila ce que j'ai détecté.

Quand je connecte ma carte Nano, dans l'onglet outil la ligne "Port" est en gris clair donc non opérationnelle.
Par contre avec la carte Uno, dans l'onglet outil la ligne "Port" est opérationnelle et m'identifie sur quel port Com est connecté la carte.

Est ce que vous avez une idée?

Merci

msport

  • Hero Member
  • *****
  • Messages: 1454
  • HO avec DCC++ en DIY Réseaux très éphémères
    • Voir le profil
Re : Message d'erreur lors du téléversement avec carte Nano
« Réponse #3 le: mars 20, 2021, 10:13:32 am »
Il faut que votre port soit coché.
Cordialement

Papa Schultz

  • Newbie
  • *
  • Messages: 17
    • Voir le profil
Re : Message d'erreur lors du téléversement avec carte Nano
« Réponse #4 le: mars 20, 2021, 10:38:27 am »
C'est bien ce que j'ai compris, sauf que la ligne "port" dans l'onglet outil, est en gris clair ce qui signifie que cette fonction du menu n'est pas active.

Merci.

Jean-Luc

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 1620
    • Voir le profil
Re : Message d'erreur lors du téléversement avec carte Nano
« Réponse #5 le: mars 20, 2021, 10:41:09 am »
Bonjour,

Le pilote pour le convertisseur USB série du Nano n'est peut-être pas installé. Quel est le modèle de convertisseur ?
Cordialement

Papa Schultz

  • Newbie
  • *
  • Messages: 17
    • Voir le profil
Re : Message d'erreur lors du téléversement avec carte Nano
« Réponse #6 le: mars 20, 2021, 11:51:00 am »
Bonjour Jean Luc,

Je n'en est aucune idée, comment puis je connaitre ce modèle?

msport

  • Hero Member
  • *****
  • Messages: 1454
  • HO avec DCC++ en DIY Réseaux très éphémères
    • Voir le profil
Re : Re : Message d'erreur lors du téléversement avec carte Nano
« Réponse #7 le: mars 20, 2021, 12:10:40 pm »
C'est bien ce que j'ai compris, sauf que la ligne "port" dans l'onglet outil, est en gris clair ce qui signifie que cette fonction du menu n'est pas active.

Pouvez vous poster une capture d'écran correspondant à celle que j'ai faite plus haut ?

Y a t il une différence entre avant et après le branchement de votre carte en USB ?

(W10) Clic droit sur l’icône Windows = Démarrer en bas à gauche
puis gestionnaire de périphériques rubrique Ports (COM et LPT), même question que précédemment
clic droit sur COM3, propriétés. -> Capture d'écran.

Avez vous eu des messages d'erreur quand vous avez installé l'IDE ?

Réinstallez le en dernier ressort. Et veillez à accepter les téléchargements connexes (remarque de Jean-Luc sur le driver CH340 qui n'est peut-être pas chargé, alors qu'il fait partie de la version 1.8.13 de l'IDE).
« Modifié: mars 20, 2021, 12:22:30 pm par msport »
Cordialement

Jean-Luc

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 1620
    • Voir le profil
Re : Re : Message d'erreur lors du téléversement avec carte Nano
« Réponse #8 le: mars 20, 2021, 01:08:30 pm »
Bonjour Jean Luc,

Je n'en est aucune idée, comment puis je connaitre ce modèle?

Le micro contrôleur est un circuit intégré carré avec des pattes sur chaque côté. Le 2e circuit intégré rectangulaire avec des pattes sur des côtés opposés est le convertisseur USB série. Qu’y a-t-il d’inscrit dessus ?
« Modifié: mars 20, 2021, 05:47:47 pm par Jean-Luc »
Cordialement

msport

  • Hero Member
  • *****
  • Messages: 1454
  • HO avec DCC++ en DIY Réseaux très éphémères
    • Voir le profil
Re : Re : Re : Message d'erreur lors du téléversement avec carte Nano
« Réponse #9 le: mars 20, 2021, 01:34:44 pm »
... comment puis je connaitre ce modèle ...
Qu’y a-t-il d’inscrit dessus ?
Suivez la flèche !
Cordialement


msport

  • Hero Member
  • *****
  • Messages: 1454
  • HO avec DCC++ en DIY Réseaux très éphémères
    • Voir le profil
Re : Message d'erreur lors du téléversement avec carte Nano
« Réponse #11 le: mars 20, 2021, 05:29:28 pm »
Oui, mais c'est en dessous que ça se passe. Lisez vous CH340 ?
Cordialement

Papa Schultz

  • Newbie
  • *
  • Messages: 17
    • Voir le profil
Re : Message d'erreur lors du téléversement avec carte Nano
« Réponse #12 le: mars 20, 2021, 05:49:08 pm »
Il n'y a absolument rien de marqué dessus.

Jean-Luc

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 1620
    • Voir le profil
Re : Message d'erreur lors du téléversement avec carte Nano
« Réponse #13 le: mars 20, 2021, 05:54:31 pm »
Si vous l'avez acheté chez ce revendeur : https://www.ebay.fr/itm/Nano-V3-0-ATMega328-CH340-Arduino-Compatible/143953697702

C'est un CH340

Cordialement

Papa Schultz

  • Newbie
  • *
  • Messages: 17
    • Voir le profil
Re : Re : Re : Message d'erreur lors du téléversement avec carte Nano
« Réponse #14 le: mars 20, 2021, 06:05:32 pm »
C'est bien ce que j'ai compris, sauf que la ligne "port" dans l'onglet outil, est en gris clair ce qui signifie que cette fonction du menu n'est pas active.

Pouvez vous poster une capture d'écran correspondant à celle que j'ai faite plus haut ?

Y a t il une différence entre avant et après le branchement de votre carte en USB ?

(W10) Clic droit sur l’icône Windows = Démarrer en bas à gauche
puis gestionnaire de périphériques rubrique Ports (COM et LPT), même question que précédemment
clic droit sur COM3, propriétés. -> Capture d'écran.

Avez vous eu des messages d'erreur quand vous avez installé l'IDE ?

Réinstallez le en dernier ressort. Et veillez à accepter les téléchargements connexes (remarque de Jean-Luc sur le driver CH340 qui n'est peut-être pas chargé, alors qu'il fait partie de la version 1.8.13 de l'IDE).

Impossible de faire une capture d'écran.

Aucune différence entre avant et après le branchement.

Pas de message d'erreur à l'installation de l'IDE. (version 1.8.13)