Auteur Sujet: Problème de retour d'info des decodeurs  (Lu 1324 fois)

Dominique

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 1702
  • 100% Arduino et N
    • Voir le profil
Re : Problème de retour d'info des decodeurs
« Réponse #30 le: août 20, 2019, 12:58:41 pm »
Il est intéressant de comparer DCCpp à des centrales du commerce. J’ai une Marklin MS2. Si elle détecte un décodeur alors que DCCpp ne détecte pas, alors je vais noter ce cas et regarder de plus près.

Thierry

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 500
    • Voir le profil
Re : Problème de retour d'info des decodeurs
« Réponse #31 le: août 23, 2019, 09:48:12 am »
Il semble qu'une réponse ait été trouvée sur ce problème sur le forum du créateur de DCC++ :

https://www.trainboard.com/highball/index.php?threads/dcc-issues-with-d-h-10c-resolved.106064/#post-1105369

La solution de ce forumiste : changer un peu les paquets d'attente de réponse -trois paquets de reset- qui sur ses décodeur D&H empêchaient l'envoi du ACK. La modif a d'ailleurs été confirmée par le service technique de D&H . Il a aussi modifié un peu la manière de chercher l'info en réduisant de moitié le nombre de mesures de courant et en passant à 5 au lieu de 30 la sensibilité de la détection...

Je joins les fichiers modifiés pour ceux qui veulent tester sur leur décodeurs récalcitrants. Reste à vérifier que ça marche encore sur les autres !

bobyAndCo

  • Global Moderator
  • Sr. Member
  • *****
  • Messages: 357
  • HO avec DCC++
    • Voir le profil
Re : Problème de retour d'info des decodeurs
« Réponse #32 le: août 23, 2019, 09:51:42 am »
Ah, un grand merci à toi Thierry. Je m'en vais tester cela au plus tard ce WE. Si cela pouvait fonctionner ce serait un vrai plus.

Bien amicalement.

Christophe

Dominique

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 1702
  • 100% Arduino et N
    • Voir le profil
Re : Problème de retour d'info des decodeurs
« Réponse #33 le: août 23, 2019, 11:54:44 am »
Merci Thierry,

Je vais tester cela dès que possible avant de se voir dans 8 jours.

Amicalement
Dominique

Dominique

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 1702
  • 100% Arduino et N
    • Voir le profil
Re : Re : Problème de retour d'info des decodeurs
« Réponse #34 le: août 23, 2019, 11:49:34 pm »
Il semble qu'une réponse ait été trouvée sur ce problème sur le forum du créateur de DCC++ :

https://www.trainboard.com/highball/index.php?threads/dcc-issues-with-d-h-10c-resolved.106064/#post-1105369

La solution de ce forumiste : changer un peu les paquets d'attente de réponse -trois paquets de reset- qui sur ses décodeur D&H empêchaient l'envoi du ACK. La modif a d'ailleurs été confirmée par le service technique de D&H . Il a aussi modifié un peu la manière de chercher l'info en réduisant de moitié le nombre de mesures de courant et en passant à 5 au lieu de 30 la sensibilité de la détection...

Je joins les fichiers modifiés pour ceux qui veulent tester sur leur décodeurs récalcitrants. Reste à vérifier que ça marche encore sur les autres !

J'ai fait la modification dans ma fonction readCV_Main() (remplacer "loadPacket(0,resetPacket,2,1);" par "loadPacket(0,bRead,3,1);") qui sert à trouver l'adresse d'une loco sur vie principale :
 et voilà ce que ça donne :
- avec mon petit autorail Ganter (je sais pas quel type de décodeur s'y ytrouve) : pas de changement ça marche comme avant !
- avec mon autorail ABKJ Etat (décodeur CT Electronic) : ça ne marche toujours pas (snif !)
je vais tester mes autres locos...

Dominique

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 1702
  • 100% Arduino et N
    • Voir le profil
Re : Re : Problème de retour d'info des decodeurs
« Réponse #35 le: octobre 07, 2019, 08:38:38 am »
L'idée serait peut-être de la mettre à la place du moteur ?

Oui, de toute évidence  ;D

bobyAndCo

  • Global Moderator
  • Sr. Member
  • *****
  • Messages: 357
  • HO avec DCC++
    • Voir le profil
Re : Problème de retour d'info des decodeurs
« Réponse #36 le: octobre 07, 2019, 07:07:23 pm »
Désolé, j'avais fait les tests également mais je n'avais pas répondu, sans doute par ce que dépité ! En effet, comme Dominique, ça n'a absolument rien changé !!!

msport

  • Hero Member
  • *****
  • Messages: 654
  • HO avec DCC++ en DIY Réseaux très éphémères
    • Voir le profil
Re : Problème de retour d'info des decodeurs
« Réponse #37 le: octobre 07, 2019, 09:26:52 pm »
Encore un mystère de plus :
sur un petit locotracteur V36 de LENZ, tentative de reset du décodeur avec DCCpp sans résultat alors que les CV se modifient.
passage sur une z21 de ROCO : reset réussi du premier coup.
J'ai constaté qu'avec la z21 l'opération s'est faite en deux temps (deux frémissements rapprochés)
Conclusion, ce n’est pas qu'une question de timing et de tension (z21 = 18V), mais aussi de protocole ?
Cordialement

Dominique

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 1702
  • 100% Arduino et N
    • Voir le profil
Re : Problème de retour d'info des decodeurs
« Réponse #38 le: octobre 08, 2019, 11:06:31 am »
Tout à fait d’accord.
Il faut utiliser l’oscilloscope à mémoire maintenant pour avancer (je n’en ai pas malheureusement)

trimarco232

  • Newbie
  • *
  • Messages: 27
    • Voir le profil
Re : Problème de retour d'info des decodeurs
« Réponse #39 le: octobre 09, 2019, 01:04:10 pm »
noël approche  ;)