Voir les contributions

Cette section vous permet de consulter les contributions (messages, sujets et fichiers joints) d'un utilisateur. Vous ne pourrez voir que les contributions des zones auxquelles vous avez accès.


Messages - PETER41

Pages: [1]
1
Discussions ouvertes / Re : Pertubations entre Arduinos
« le: juillet 13, 2022, 09:02:55 pm »
Bonjour à tous,
Voici en pièce jointe un document que j'ai réalisé pour la documentation du club.
De même je met le programme en pièce jointe. Je ne l'ai pas conçu mais simplement fait une adaptation à mon besoin.
Ce programme n'est donc pas établi par moi mais simplement un programmeur adaptateur et ce programme donne satisfaction.

Encore merci à tous pour votre contribution.
Aduinotement vôtre
Pierre

2
Discussions ouvertes / Re : Pertubations entre Arduinos
« le: juillet 12, 2022, 03:13:32 pm »
Bonjour à tous,
J'ai une bonne nouvelle. Mais avant je vais donc repréciser le montage.
L’Arduino utilisé est une carte digispark USB.
L'alimentation se fait en 12v, un régulateur 5V est installé sur mon circuit imprimé pour alimenter avec la bonne valeur d e tension pour le servo.
Je ne sais pas si la commande pinMode(pinX, INPUT_PULLUP) est possible sur cette carte digispark.
J'ai donc mis  deux condensateur (un sur chaque entrée) au niveau de ma carte circuit imprimé. Il apparaît que le servo n'est plus commandé correctement car il revient "en arrière" (sens horaire)  avant d'aller vers l'avant (sens anti horaire) pour un des deux mouvements.
J'ai supprimé un des condensateurs et OH MIRACLE, le fonctionnement est OK !
Le condensateur qui reste est donc sur l'entrée P1 (celui qui a été supprimé était sur l'entrée P0).
P2 étant la sortie qui alimente le servo.
J'espère avoir été assez clair.
Encore merci pour votre aide.
Arduinotement vôtre.
Pierre
PS : J'ai mis en fichier joint une image de la carte pour que cela soit plus clair. Je n'ai pas réussi à insérer une image dans le texte.

3
Cher MSPORT,
Je viens de télécharger ton PRG. Mais comme je n'ai pas fait TRES attention au premier essai PAF le chien.
Ensuite j'ai regardé ton PRG et j'ai vu que l'adresse de début était 10 ... Petit piège car j'ai fait mon premier test à partir de l'adresse 90 ! C'est ce qui était pour le 3 leds et que TRIMARCO232 avait pris aussi.
Et là essai à partir de l'adresse 10 tout fonctionne : BRAVO et surtout UN GRAND MERCI pour ton aide.

Dois-je déduire que le PRG de TRIMARCO que j'ai fait en copier coller pose un PB par cette méthode de copier coller (et non pas du PRG lui-même).
Encore tous mes remerciements à vous deux. Cela me (nous) montre que la communauté ARDUINO est TOP.
Je ferais des photos des cartes et je les mettrais sur le forum.
ARDUINOTEMENT VOTRE
Pierre

4
Discussions ouvertes / Re : Pertubations entre Arduinos
« le: juillet 08, 2022, 01:30:02 pm »
Bonjour,
Ce n'est pas l'Attiny 85 qui alimente le servo car j’alimente la carte en 12 V et j'ai mis un régulateur 5V.
La longueur entre le commutateur est d'environ 1m par un câble plat 3 conducteurs. Je pense essayer samedi de mettre un câble blindé : est-ce une solution ?
Les deux entrées du commutateur sont misent en pullup par des résistances de 1k relié au +5V du régulateur qui alimente l'Attiny (en fait c'est 5.6V car j'ai mis une diode sur la masse du régulateur afin d'avoir un peu plus de 5V pour alimenter l'Attiny).
Concernant ta proposition de mettre deux 100 nF sur les entrées, je tenterais cela samedi au club.
Une idée qui me viens : Est-ce intéressant (nécessaire) que le 0V l’alimentions lumière soit relié au 0V de l'alimentation 12 V "accessoire" (je dis accessoire pour indiquer que cette alimentation va permettre de gérer les allumages des bâtiments, des réverbères, etc par l'Arduino Nano qui gère l'éclairage). Je crois bien que cela doit être absolument nécessaire.
Arduinotement vôtre.
Pierre

5
Discussions ouvertes / Pertubations entre Arduinos
« le: juillet 07, 2022, 05:33:04 pm »
Bonjour à tous,
J'ai un PB au club, je m'explique.
J'ai réalisé un éclairage leds (2 rubans leds blanc chaud et 1 ruban RVB) piloté par un Arduino Nano avec une cde en manuelle par 4 potentiomètres ou en automatique avec un cycle jour nuit en intervenant sur les ruban blanc et le ruban RVB. Pour faire la variation de l'intensité de la lumière j'utilise les sorties en PWM. Cela fonctionne à merveille. En sachant que les autres sorties disponibles cde différents éclairages situés sur le réseau (éclairage maison, réverbère, silo, etc).
Nous avions besoin de commander un aiguillage sans pour autant acheter un moteur TORTOISE (comme d'habitude). J'ai donc réalisé un circuit imprimé avec un arduino digispark qui par l'intermédiaire d'un commutateur 2 positions cde un servomoteur.
Si j’alimente le montage avec une alimentation totalement autonome le fonctionnement est nickel.
Si j'alimente le montage par l’intermédiera d'une alimentation 12 V DC qui est distribuée sous le réseau afin de pouvoir alimenter n'importe quel montage ET que la lumière citée précédemment est en action j'ai un fonctionnement bizarre pour l'une des commandes par mon inter : le servomoteur est commandé aléatoirement et n'importe comment en faisant comme un "essuie glace". Je coupe l’alimentation des lumières (qui est totalement indépendante de l'alim 12 V DC) le fonctionnement du servomoteur est nickel.
Il y a donc une perturbation entre "lumière" et l'Arduino qui commande le servo.

Pouvez-vous m'indiquer une piste de solution ? J'ai mis un condo 100nF au plus près de l'alim de l'Arduino qui commande le servo et cela n'a pas donné le fonctionnement correct.
Merci pour votre aide.
Arduinotement vôtre.
Pierre

6
Bonjour à tous,
Voici les nouvelles :
Il semblerait que les commandes DCC ne sont pas effectives :
1- Supposition 1 : L'optocoupleur a un PB. J'ai donc pris l'optocoupleur de la carte 3 leds et je l'ai mis sur la carte 4 leds. Même effet.
J'ai même mis l'optocoupleur de la carte 4 leds sur la carte 3 leds et la carte 3 leds fonctionne.
Donc optocoupleur OK
2- Pb de la carte CI que j'ai fait : J'ai donc mis l'Arduino avec le PRG 3 leds et la carte fonctionne parfaitement. Donc le CI est OK.
J'ai mis l'Arduino avec le prg 4 leds sur la carte 3 leds et le fonctionnement n'est pas bon : les cdes DCC ne produisent rien.
L'allumage des leds est celui décrit précédemment.
Pour mettre le programme dans l'Arduino j'ai fait un copier du PRG en faisant sélectionner puis copier et mis ensuite dans l'éditeur de programmation Arduino. Est-ce cela qui pose un PB. Est-il possible d'avoir le fichier .ino et téléchargement ?
Merci pour votre aide car là je bloque complètement.
Dans l'attente de votre réponse.
Arduinotement vôtre.
Pierre

7
Bonjour à tous,
La carte est câblée. Mise sous tension :
Toutes les leds red sont allumées, les leds "carré" sont allumées mais la sortie A0 "clignote".
En mettant la console il y a en effet une commande alternée red puis carre + red. Donc cela produit le clignotement de la led carre.
J'avais fait un essai la semaine dernière et cela faisait cela au club même quand le DCC était alimenté et avec la manette ROCO impossible de commander les feux. Mais je n'avais pas l'ordinateur portable et je ne pouvais pas voir ce qui se passait.
Je ferais un nouvel essai demain AM.
Je ne comprends donc pas ce qui se passe. Je n'ai pas mis de condensateur sur les entrées de l'optocoupleur. Sur la version 3 leds non plus et cela fonctionne donc ?
Je me suis dit que mon circuit avait un PB. J'ai donc fait un câblage sur bredboard et cela produit le même effet (sans signal DCC). Pourtant en regardant les photos de MSPORT cela fonctionne !
Je vous donne des nouvelles jeudi après essai au club demain AM.
Arduinotement vôtre
Pierre

8
Bonjour à tous,
Un très grand merci pour ce travail.
Pour ma part j'ai dessiné la carte imprimé et j'espère la câbler d'ici mercredi prochain pour faire l'essai au club.
Je vous tiendrais informé dès que j'aurais fait ces essais (centrale digikeys et logiciel Trancontroller Gold).
Arduinotement vôtre.
Pierre

9
Discussions ouvertes / Re : Locoduino à Orleans
« le: novembre 12, 2018, 10:32:01 pm »
Bonsoir Maxou9914,
Marcel t'a donné le lien qui va bien.
Par contre si tu souhaites piloté comme moi deux écrans en même temps, avoir le plan du circuit imprimé qui va bine, je peux te donner plus d'infos.
Pour cela tu peux me mettre un mail à train.pierre@free.fr et je te répondrais.

Arduinotement vôtre.
Pierre G

10
Discussions ouvertes / Re : Locoduino à Orleans
« le: novembre 12, 2018, 02:41:46 pm »
Bonjour à tous,
En effet je confirme que cette exposition a été une réussite.
De très beaux réseaux et surtout notre participation dont j'ai été un peu à l'origine.
Nous devions être présent pour rencontrer nos "amoureux" du "faire nous même" que nous accompagnons soit par le site soit par le forum.

Ces rencontres nous permettent que le chemin que nous avons pris est le bon.

Que nos visiteurs en soient remerciés et encore bravo aux bénévoles qui ont animés le stand.

Pour ma part j'ai fait aussi un peu "d'effet" avec la découpe carton et à la demande générale, je vais d'ici quelques semaines vous proposer un article sur l'association Arduino et découpe de carton sur une réalisation très peu couteuse et qui animera votre réseau.
Était présenté sur notre stand, Fond d'usine avec éclairage animé, Poste de triage, Affichage "pub" sur écran Oled, Moulin à vent, etc.

Arduinotement vôtre.
Pierre G

Pages: [1]