Auteur Sujet: BAL 8 cantons analogiques _ pb avec le transformateur  (Lu 784 fois)

Frédéric043

  • Newbie
  • *
  • Messages: 1
    • Voir le profil
BAL 8 cantons analogiques _ pb avec le transformateur
« le: février 28, 2024, 10:41:08 pm »
Bonjour,

Je m'initie à Arduino et à son utilisation pour la gestion automatique d'un réseau que j'ai adapté pour 6 cantons analogiques à partir de l'article publié sur Locoduino BAL à 8 cantons analogiques par Christian Bézanger.

Tout fonctionne parfaitement si j'utilise un aimant pour activer les ILS.
J’ai cependant un souci, un conflit il me semble entre le transformateur d’alimentation et la carte relai.

La 1ère photo montre les branchements (hormis les feux de signalisation, pour l'instant en attente). A la mise en route du transfo via l'interrupteur, 2 relais s'enclenchent !
Si on ne branche qu’un seul ILS à la carte arduino (photo 2), (exemple, l’ILS du canton 2), l’interrupteur on/off du transfo déclenche le relai n°1 sans que je n'exerce aucune autre action extérieure !

J’avoue ne pas comprendre...
Auriez vous une idée ?

Merci pour votre aide
Bonne journée
Frédéric

bobyAndCo

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 913
  • HO avec DCC++
    • Voir le profil
Re : BAL 8 cantons analogiques _ pb avec le transformateur
« Réponse #1 le: mars 01, 2024, 03:08:44 am »
Frédéric,

Impossible d’apporter un diagnostic avec juste des fils sur une photo. Si tu penses que cela peut être un problème matériel, il faut alors faire tourner un programme Arduino très simple qui consiste à activer alternativement chaque relais sans ILS à ce stade.

C’est le petit programme que j’ai mis en PJ. Pour les pins, j'ai mis ce que je crois voir sur la photo (2 à 9) mais à vérifier.

Si tout fonctionne ici, il faudra joindre le programme. Il est probable que le programme soit écrit de telle manière à ce que justement l'un des relais soit activé par défaut et pas l’autre au démarrage.

A suivre donc

Christophe
« Modifié: mars 01, 2024, 03:10:24 am par bobyAndCo »

chris_bzg

  • Global Moderator
  • Sr. Member
  • *****
  • Messages: 311
    • Voir le profil
Re : BAL 8 cantons analogiques _ pb avec le transformateur
« Réponse #2 le: mars 01, 2024, 06:12:02 pm »
La deuxième photo étant floue, on ne va pas en parler. Quant à la première, on voit effectivement le branchement Arduino -> entrées de commande des relais (et cela semble correcte) mais on ne comprend rien des fils qui partent du transfo vers les sorties de la carte relais. Ces fils (courant de traction) sont en marron et orange sur la figure 2 de l'article. Essayez de ne câbler que ce qui concerne le relais 1 et faites une photo qui nous permette de comprendre (notamment, aucun fil ne doit sortir du plateau car on ne peut pas voir d'où il vient et où il va). Autre question : comment est alimentée la carte relais ?
Si vous voulez qu'on vous aide, il va falloir nous aider un peu...

chris_bzg

  • Global Moderator
  • Sr. Member
  • *****
  • Messages: 311
    • Voir le profil
Re : BAL 8 cantons analogiques _ pb avec le transformateur
« Réponse #3 le: mars 02, 2024, 12:25:24 pm »
Décidément, le montage n'a pas évolué depuis l'époque de cette photo retrouvée dans mes archives (fortes ressemblances tout de même).
Doit-on vous appeler Frédéric ou Alain ?
Une chose me tracasse ; on voit sur la photo que vous avez postée plus haut, que vous alimentez la carte relais avec une alimentation délivrant du 15 V. N'est-ce pas un peut trop pour une carte relais en 5 V ? Voilà peut-être où il faut commencer à chercher...