Auteur Sujet: Attiny 85  (Lu 270 fois)

pn200

  • Newbie
  • *
  • Messages: 31
    • Voir le profil
Attiny 85
« le: avril 02, 2024, 03:05:34 pm »
Bonjour,
Je n'arrive plus à téléverser. J'ai essayé avec 3 UNO et les 2 drivers (340, 341), j'ai toujours le même message "Upload error: A programmer is requied to upload". J'ai toujours le même montage pour ces Attiny , j'en ai plusieurs sur mon réseau et jamais de soucis.
Bonne journée.
Bernard

bobyAndCo

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 913
  • HO avec DCC++
    • Voir le profil
Re : Attiny 85
« Réponse #1 le: avril 02, 2024, 10:15:54 pm »
C'est un problème que j'ai signalé sur le site éditorial des articles de Christian sur les ATTiny.

J'ai exactement le problème que j'ai avec les versions 2.xx de l'IDE Arduino mais pas sur les versions 1.8x. Du coup, je n'ai pas cherché plus loin et j'utilise la version 1.8x.

Je suis sur Mac (M2) Ventura 13.0 mais ma version 1.8x de l'IDE tourne sur un 10.14.6 Mojave (Intel). Et toi ???

chris_bzg

  • Global Moderator
  • Sr. Member
  • *****
  • Messages: 311
    • Voir le profil
Re : Attiny 85
« Réponse #2 le: avril 03, 2024, 12:28:32 pm »
Oui, effectivement Christophe m'a fait part de ce problème.
Je suis désolé mais je n'ai pas encore eu le temps de me pencher dessus ; mon fils est arrivé des Etats-Unis hier et repart en fin de semaine, donc j'essaierai de regarder cela en début de semaine prochaine, si tout va bien.
Si je trouve quelque chose, je vous tiens au courant. En attendant, on peut se rabattre sur la version 1.8.19 qui permet la programmation. Mais il doit bien y avoir une raison pour que la 2.x ne le permette pas et ce n'est peut-être pas grand chose à résoudre.  ;)

pn200

  • Newbie
  • *
  • Messages: 31
    • Voir le profil
Re : Attiny 85
« Réponse #3 le: avril 03, 2024, 09:18:54 pm »
Bonsoir,
Par contre on peut graver la séquence d'initialisation.

bobyAndCo

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 913
  • HO avec DCC++
    • Voir le profil
Re : Attiny 85
« Réponse #4 le: avril 04, 2024, 10:28:34 am »
@pn200

Peux tu préciser sur quel OS tu es et version OS ?

Christophe

pn200

  • Newbie
  • *
  • Messages: 31
    • Voir le profil
Re : Attiny 85
« Réponse #5 le: avril 04, 2024, 09:23:32 pm »
Bonsoir bobyAndCo,
Je suis sur Windows 11 (23H2).
J'ai mis la version 1.8.18, le téléversement se fait sans erreur. Essai: Blink fonctionne.

bobyAndCo

  • Global Moderator
  • Hero Member
  • *****
  • Messages: 913
  • HO avec DCC++
    • Voir le profil
Re : Attiny 85
« Réponse #6 le: avril 05, 2024, 07:33:42 am »
Donc Mac ou PC, le problème est le même. Avis aux amateurs d'ATTiny, il faut garder une version 1.8x quelque part pour faire le chargement de programmes.

J'ai vu qu'il existait une solution sur PlatteformIO mais je n'ai pas testé : https://docs.platformio.org/en/stable/boards/atmelavr/attiny44.html#hardware