Auteur Sujet: Problème de lecture et programmation de CVs avec DCC++  (Lu 186 fois)

bobyAndCo

  • Global Moderator
  • Sr. Member
  • *****
  • Messages: 362
  • HO avec DCC++
    • Voir le profil
Problème de lecture et programmation de CVs avec DCC++
« le: août 05, 2019, 07:14:01 am »
Bonjour à tous,

J’ouvre ce nouveau fil suite à un commentaire à l’article sur Une station DCC complète, polyvalente et économique avec JMRI : http://www.locoduino.org/spip.php?article253 où Jean évoque des problèmes de lecture et de programmation de CV avec JMRI, mais qui est en réalité relèvent de DCC++.

C’est un problème que j’avais soulevé il y a maintenant plus de trois ans, que Dominique aussi à rencontré, et puis comme on a toujours plus ou moins réussi à contourner le problème, c’est quelque chose que l’on a jamais approfondi et pour lequel, de fait, on n’a jamais trouvé de solution.

Si quelqu’un a la solution, nous sommes bien sûr preneur. Dans la négative, je souhaiterais que ceux qui connaissent ce problème puissent contribuer à établir un inventaire des marques de décodeurs concernés et éventuellement des modèles. Il semble bien que cela ne concerne que certains fabricants et pas d’autres.

Il est intéressant de savoir si ces problèmes sont cantonnés à la seule voie de programmation ou concernent aussi la voie principale, et de savoir également, sur la voie principale, quels sont les CVs qui peuvent être reprogrammées.

Enfin, toute proposition qui pourrait contribuer à trouver la réponse est bien sûr la bien venue.

Merci par avance.

fcot2002

  • Jr. Member
  • **
  • Messages: 61
    • Voir le profil
Re : Problème de lecture et programmation de CVs avec DCC++
« Réponse #1 le: août 05, 2019, 01:34:04 pm »
Bonjour @ tous  8)

Le problème j'ai rencontré n'est pas lié à un type de décodeur, mais était identique avec plusieurs décodeurs testés.

J'étais en version DCC++ : Mega + shield Ethernet + shield Motor. Connexion Ethernet avec JMRI

La simple lecture / identification d'une machine via DecoderPro prenait......  5 minutes ! ! ! Avec aléatoirement des erreurs de lectures.

Je passe en version DCC++ : Mega + shield Motor. Connexion USB avec JMRI

Disparition totale du problème, lecture / identification <15 secondes.

Je me dis mon shied Ethernet est HS. Je monte une centrale DCC++ Mega + Ethernet + Motor complètement neuve : Lecture / identification problématique. On passe en USB sans enlever le shield Ethernet : aucun souci lecture / identification < 15 secondes.

J'ai arrêté de chercher, mais je n'aime pas ne pas comprendre.....

Voila Christophe ma contribution   ;) ;) ;)

Bonnes vacances @ ceux qui y sont, bon courage aux autres