Voir les contributions

Cette section vous permet de consulter les contributions (messages, sujets et fichiers joints) d'un utilisateur. Vous ne pourrez voir que les contributions des zones auxquelles vous avez accès.


Messages - Juan

Pages: [1] 2 3 ... 6
1
Le pad_70_avant.pdf est correct, je suis d'accord.  Mais l'avant /2 ? Je ne comprends pas : ne devrait-il pas être l'image miroir de l'avant ? Je pense qu'il appartient à une autre version du PCB : le module HC-12 est en transversal, il n'est donc pas sur mes PCB.

2
Pardonnez-moi d'être aussi pénible  :-[ , mais êtes-vous sûr que les fichiers PDF correspondant au Dessin du circuit imprimé à l'échelle 1 sont corrects ?
Je n'arrive pas à le voir clairement.

3
Bonjour msport,
Non, ce n'est pas cette ligne. Ce qui doit être modifié se trouve dans void doDCCpoint () :
Serial.print ((( PointAddressDble / 2 - 1 ) / 4) + 1 ) ; Dans mon cas, je le remplace par :
Serial.print ((( PointAddressDble / 2 - 1 ) / 4) + 2 ) ; Et dans void doPointLCD () je change la ligne
tft.print((((PointAddressDble / 2 - 1) / 4) + 1, DEC ) ;pour celui-ci
tft.print((((PointAddressDble / 2 - 1) / 4) + 2, DEC ) ;
De cette façon, l'aiguillage 1 a l'adresse 5 (2/0), comme vous pouvez le voir sur l'image.

Maintenant, je devrais faire quelque chose de similaire avec les accessoires, mais je m'embrouille,  :'( donc une autre fois.

Je vous dirai aussi que j'ai testé toute la manette, y compris le HC-12, et que tout fonctionne bien  :).  Il ne me reste plus qu'à mettre la plaque dans la boîte, ce qui est déjà pas mal. Quand je l'aurai, je téléchargerai une photo.
Cordialement
Juan

4
Vos projets / Re : projet centrale "LaBox" wifi DCC++ Can
« le: novembre 14, 2022, 01:18:07 pm »
Bonjour Thierry
Je suis très heureux que vous soyez de retour au LaBox, mais pourquoi pas un article dans Locoduino ?
J'aimerais vraiment faire cette centrale, mais en suivant les messages sur le Forum, c'est très compliqué pour moi.
Je crois sincèrement qu'un article dédié dans Locoduino serait la bombe !
Cordialement,
Juan

5
Une dernière question. ;D ;D ;D.. ... pour l'instant.
Sur mon réseau, il y a neuf aiguillages, leurs adresses commencent par 5 -> 2/0. Que dois-je modifier dans le croquis pour que l'aiguillage 1 reçoive l'adresse 2/0, et ainsi de suite ?

6
Gracias msport
Je m'étais déjà souvenu des quatre chiffres de l'adresse.
Quant à debug = 0/1, je ne sais pas, j'ai essayé d'utiliser les deux types d'alimentation, avec FTDI ou avec la batterie uniquement. Dans les deux cas, je dois définir debug=1 pour les fonctions.

7
Une curiosité : dans quel octet (ou autre) de l'EEPROM se trouvent les adresses des quatre locomotives ? Parce que je pouvais faire le test en les écrivant directement dans l'EEPROM.

8
Bonjour à tous
Eh bien, avant de passer à l'autre sujet, qui, je l'espère, ne sera pas trop compliqué, terminons par la manette, car j'ai quelques questions en suspens. A savoir :
1.- Pourquoi le problème a-t-il été résolu, dans mon cas, lorsque j'ai mis debug=1 ? Quelle en est la raison ? Est-ce que cela fonctionne pour vous avec debug=0 ?
2 - Je n'arrive pas à enregistrer l'adresse des locos. Je suis les instructions : *-adresse numéro-#, mais l'adresse ne change pas, elle est toujours 00.

L'affaire n'en finit pas ! >:(
Cordialement
Juan

9
ATTENTION, MESDAMES ET MESSIEURS :
Cela semble déjà fonctionner. Et sur le PCB complet, comme vous pouvez le voir sur la photo.
Et comment je l'ai réparé ? Très simple. Dans le sketch, ligne 106 int debug = 0 ; changer par int debug = 1 ;
Et tout est réparé. La raison ? Je n'en ai aucune idée.

Bon, maintenant je dois tester si le HC-12 fonctionne, mais ce sera pour un autre jour.

Msport et tous les autres, merci beaucoup de m'avoir supporté et de m'avoir aidé. Demain, je continuerai à vous ennuyer avec un autre sujet que j'ai en tête, mais demain.
Cordialement
Juan

10
J'ai oublié la photo avec le Uno.

11
J'ai fait un autre test sur le breadboard en utilisant un Uno.  Résultat :
1.- le codeur fonctionne
2 - Je tape sur une touche et il ne fait rien : il ne se réinitialise pas mais il ne réagit pas non plus à la touche.
3.- l'encodeur ne fonctionne plus

QUE FAIRE D'AUTRE ?

Je pourrais essayer avec un Nano sur la planche à pain, mais franchement, je n'en ai plus envie.

12
Msport, il semble que nous ayons pensé la même chose. Mais malheureusement, il continue à se réinitialiser. Et je n'ai pas d'autres pro minis avec les mêmes caractéristiques.
Bien que la semaine prochaine, j'espère en recevoir quelques-uns. Mais je ne sais pas si je vais pouvoir tenir le coup !

13
Bonjour.
Ce que j'ai dit avant, je le comprends de moins en moins. J'ai fait un montage minimal de la manette : Pro Mini, écran TFT et encodeur (avec sa résistance de 10k). Rien de plus.

Mais le problème reste le même : l'encodeur fonctionne parfaitement, mais dès que je tape sur une touche (avec une pincette), il se réinitialise.
Une explication, s'il vous plaît, avant que ne me tue !

14
Salut msport
Citer
Je ne vois comme proposition que de refaire le montage avec le circuit de droite
C'est précisément ce que j'avais l'intention de faire. Et je vais le faire étape par étape. Dans un premier temps, je vais monter l'essentiel, c'est-à-dire : Pro mini, écran TFT, encodeur et un bouton poussoir.
En l'alimentant par USB, je pense que cela devrait suffire à le faire fonctionner, non ?
Juan.

15
Allo, msport,
Je réponds à vos questions:
Citer
Le codeur rotatif a t il été testé via le serial monitor ?
Voici ce que j'obtiens:
<1><1><t1 0 1 1>
<1><t1 0 6 1>
<1><t1 0 7 1>
<1><t1 0 8 1>
<1><t1 0 11 1>
<1><t1 0 12 1>
<1><t1 0 13 1>
<1><t1 0 14 1>
<1><t1 0 15 1>
<1><t1 0 14 1>
<1><t1 0 10 1>
<1><t1 0 7 1>
<1><t1 0 6 1>
<1><t1 0 5 1>
<1><t1 0 3 1>
<1><t1 0 2 1>
<1><t1 0 1 1>
<1><t1 0 0 1>

Citer
L'alimentation vient du module FTDI ? Testé via batterie + step up ?
Je le fais des deux façons, avec les mêmes résultats.

Citer
Peut-on tester sans l'afficheur avec le module FTDI sur le serial monitor ?
Oui, je le fais et les mêmes résultats

Citer
Un module HC12 est-il branché ?
J'ai essayé les deux façons, même résultat

Citer
Les quatre adresses ne peuvent être choisies qu'avec un clavier OK. (via la Touche *)
Il semblerait que les adresses aient été déjà saisies une fois. Est-ce le cas ?
En effet, grand mystère. Je les ai probablement insérés avec le keyboard lorsque j'ai fait un test sur une planche à pain il y a quelque temps et cela a fonctionné.
Maintenant, j'ai effacé l'EEPROM et ils n'apparaissent plus.

Merci beaucoup, nous allons continuer à rechercher.
Juan.


Pages: [1] 2 3 ... 6