Voir les contributions

Cette section vous permet de consulter les contributions (messages, sujets et fichiers joints) d'un utilisateur. Vous ne pourrez voir que les contributions des zones auxquelles vous avez accès.


Messages - chris_bzg

Pages: [1] 2 3 ... 20
1
Débuter / Re : message exit satus 1
« le: Aujourd'hui à 12:49:24 pm »
Visiblement, c'est lors du téléversement qu'il y a une erreur.
Il faut donc que nous en sachions un peu plus sur votre environnement de travail.
Quel système d'exploitation utilisez-vous ?
Quelle version de l'IDE ?
Quel type de carte Uno (Arduino ou clone) ?

Essayez de téléverser le programme Blink en ayant changé le rythme de clignotement. Avez-vous le même problème ?

2
Aide / Re : Attiny 85
« le: avril 03, 2024, 12:28:32 pm »
Oui, effectivement Christophe m'a fait part de ce problème.
Je suis désolé mais je n'ai pas encore eu le temps de me pencher dessus ; mon fils est arrivé des Etats-Unis hier et repart en fin de semaine, donc j'essaierai de regarder cela en début de semaine prochaine, si tout va bien.
Si je trouve quelque chose, je vous tiens au courant. En attendant, on peut se rabattre sur la version 1.8.19 qui permet la programmation. Mais il doit bien y avoir une raison pour que la 2.x ne le permette pas et ce n'est peut-être pas grand chose à résoudre.  ;)

3
Vos projets / Re : Mise en place PN suivant l'article 263
« le: mars 25, 2024, 11:46:36 am »
Bonne nouvelle !
Donc, si j'ai bien compris, tout fonctionne maintenant comme cela était annoncé dans l'article 263 ?
Je m'en réjouis et je reste à ta disposition au besoin.

4
Aide / Re : BAL 8 cantons analogiques _ pb avec le transformateur
« le: mars 02, 2024, 12:25:24 pm »
Décidément, le montage n'a pas évolué depuis l'époque de cette photo retrouvée dans mes archives (fortes ressemblances tout de même).
Doit-on vous appeler Frédéric ou Alain ?
Une chose me tracasse ; on voit sur la photo que vous avez postée plus haut, que vous alimentez la carte relais avec une alimentation délivrant du 15 V. N'est-ce pas un peut trop pour une carte relais en 5 V ? Voilà peut-être où il faut commencer à chercher...


5
Aide / Re : BAL 8 cantons analogiques _ pb avec le transformateur
« le: mars 01, 2024, 06:12:02 pm »
La deuxième photo étant floue, on ne va pas en parler. Quant à la première, on voit effectivement le branchement Arduino -> entrées de commande des relais (et cela semble correcte) mais on ne comprend rien des fils qui partent du transfo vers les sorties de la carte relais. Ces fils (courant de traction) sont en marron et orange sur la figure 2 de l'article. Essayez de ne câbler que ce qui concerne le relais 1 et faites une photo qui nous permette de comprendre (notamment, aucun fil ne doit sortir du plateau car on ne peut pas voir d'où il vient et où il va). Autre question : comment est alimentée la carte relais ?
Si vous voulez qu'on vous aide, il va falloir nous aider un peu...

6
Aide / Re : Un gestionnaire en C++ pour votre réseau (1)
« le: février 27, 2024, 12:04:57 pm »
Bonjour,

J' essaie de faire un TCO en utilisant les articles "processing" et "Un gestionnaire en C++ pour votre réseau " qui sont super bien expliqué, je ne trouve pas comment créer ou déclarer une "zone"

amicalement
frederic

Je vous invite également à lire l'article https://www.locoduino.org/spip.php?article226 qui reprend le travail de Pierre59 sur un cas de réseau simple, en ajoutant la partie communication entre Processing et Arduino dans le but que le TCO contrôle le réseau.
Pour ma part, c'est ainsi que je commande mon réseau analogique en N : Processing dessine le TCO interactif et chaque fois qu'on clique sur un aiguillage, envoie l'information à une carte Arduino Uno qui commande alors des cartes relais pour alimenter les portions de voie ou les moteurs solénoïdes d'aiguillage. Dans le programme Processing, on peut entrer des règles de sécurité pour gérer le déplacement des trains. J'ai décrit cela dans Loco-Revue également, en citant également les articles de Pierre et de Denis (DDEF) qui m'ont fait gagner un temps précieux.  ;)

7
Vos projets / Re : Mise en place PN suivant l'article 263
« le: février 06, 2024, 10:34:41 am »
Tu peux tester tes servomoteurs avec les exemples de l'IDE.
Comme cela, tu sauras s'ils fonctionnent.

8
Vos projets / Re : Mise en place PN suivant l'article 263
« le: février 05, 2024, 09:52:09 am »
Ce tuto est effectivement très bien, mais le problème de Daniel n'est pas de motoriser un aiguillage, mais une barrière de PN conformément aux articles que nous avons publiés.
Son servomoteur tourne de 360° continument.
Pour moi, soit le câblage n'est pas correct avec les entrées d'ILS (ou B/P), soit le programme a été modifié (introduction de SlowMotionServo qui n'est pas nécessaire et qui a été mal utilisé).
Attendons sa réponse.

9
Vos projets / Re : Mise en place PN suivant l'article 263
« le: février 03, 2024, 02:22:40 pm »
Bien que la photo ne soit pas de très bonne qualité, je pense que votre montage est correct (j'ai un petit doute sur les poussoirs : bien reliés à l'entrée 2 et non pas 1 ?)

Ce qui m'étonne, c'est que le servo tourne sur 360° alors que logiquement, sa course devrait être 180° par construction : avez-vous utilisé un servomoteur capable de tourner de 360° (cela existe) ou bien est-ce un servo 9g classique ?

De plus, quand ça ne fonctionne pas, avez-vous utilisé le programme sans le modifier ?

Vous dites que cela fonctionne avec SlowMotionServo, ce qui est encore plus étonnant. Donc, je m'oriente vers le fait que la déclaration de l'objet Servo n'a peut-être pas été faite correctement (confusion entre Servo et SlowMotionServo ?).

Reprenez le programme tel qu'il est fourni et reprogrammez la carte (pour être certain que ce soit programmé sans SlowMotionServo qui n'est pas nécessaire). Recommencez après avoir bien vérifié le montage (doute sur entrée 2).

10
Vie du forum / Re : Re : Retour en ligne
« le: août 09, 2023, 02:43:04 pm »
Pour l'instant, le bouton "télécharger" à la fin d'un listing de programme a disparu. Mais nous allons tout faire pour le restaurer.  ;)
Cela concerne surtout les articles les plus anciens, car maintenant on donne plutôt les programmes sous formes de fichier ZIP : c'est plus pratique surtout s'il y a plusieurs onglets ou bien d'autres langages (HTML par exemple).

Visiblement, il ne sera pas possible de restaurer le bouton "Télécharger" mais pour un programme donné sous forme de listing, un simple copier-coller du code avec la souris est suffisant pour l'importer dans votre IDE (1 ou 2). On a vérifié sur plusieurs exemples et ça s'est toujours bien passé. En conséquence, j'ai fait une mise à jour de mon article https://locoduino.org/spip.php?article274 qui explique comment récupérer un programme. Les changements sont dans les figures 5 et 6 et le texte associé.

Bonnes réalisations.

11
Vie du forum / Re : Retour en ligne
« le: août 04, 2023, 01:04:11 am »
Pour l'instant, le bouton "télécharger" à la fin d'un listing de programme a disparu. Mais nous allons tout faire pour le restaurer.  ;)
Cela concerne surtout les articles les plus anciens, car maintenant on donne plutôt les programmes sous formes de fichier ZIP : c'est plus pratique surtout s'il y a plusieurs onglets ou bien d'autres langages (HTML par exemple).

En plus, pour nous les auteurs, une nouvelle interface plus conviviale pour rédiger nos articles. J'en ai d'ailleurs un en attente de validation (et oui, LOCODUINO est un site sérieux qui contrôle ce qui est publié et parfois, il faut revoir sa copie, mais grâce au travail de tous, les articles finissent par sortir avec plein d'améliorations).

Donc, pendant que Jean-Luc chassait le pirate, je vous ai concocté une surprise histoire de se faire pardonner notre petite absence.  ;)

12
Présentez vous ! / Re : Re : Je me présente Gaston30
« le: juin 17, 2023, 12:21:05 pm »

le old bootloader donne plutôt ce genre de message :

         Using Port                    : COM4
         Using Programmer              : arduino
         Overriding Baud Rate          : 57600
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xa3
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xa3

...


A ce que je vois, avrdude cherche à se connecter à l'arduino et fait 10 tentatives avant d'abandonner (ici, deux seulement sont visibles mais il y a les points de suspension). Cela me fait donc penser que l'arduino n'est pas sur le COM4 malgré ce qui est indiqué (et oui, parfois le port indiqué par l'IDE n'est pas le bon).

Je suggère donc d'utiliser le gestionnaire de périphériques de Windows 10 (moins évident qu'avec Windows 7 mais il existe toujours et il suffit de le chercher) et de voir sur quel port COM l'arduino se connecte. Ensuite il suffit de changer ce port dans l'IDE.

On peut aussi essayer à l'aveugle un autre port proposé par l'IDE et tomber sur le bon. L'idée d'utiliser l'IDE 1 au lieu de 2 est aussi une piste : une fois que ça marche, on peut essayer IDE 2 qui à son lancement, présentait quelques petites lacunes (je ne sais pas si elles ont été corrigées depuis car il y a eu d'autres versions, celle actuelle étant 2.1.0).

Bon courage (cette mésaventure m'est aussi arrivée et on s'en sort toujours).

13
Aide / Re : Carte Mega 2560 et carte relai 8 cantons
« le: juin 12, 2023, 12:33:04 pm »
Bonjour, j'ai installé Arduino Mega 2560 et carte 8 relai dont 4 sont actifs, avec une bbliothèque adéquate.
...

Pourquoi persister à utiliser une bibliothèque qui ne fonctionnait pas avec une carte Mega et qui a été retirée de l'article lors de sa mise à jour en août 2022 ? Reprenez le programme de cet article mis à jour, reprogrammez votre carte Mega et réalisez le montage tel quel pour le raccorder à votre réseau. Cela ne semble pas compliqué, la solution fournie étant fonctionnelle.

A ma connaissance, c'est le quatrième fil que vous ouvrez sur ce forum (peut-être plus) sur le même sujet. Combien allez-vous en écrire ?

Commencez, comme on vous le réclame depuis pas mal de temps, par poster une photo de votre montage pour nous prouver qu'il existe (avec connexions visibles pour que la photo soit exploitable).

Cordialement.

Pour les autres lecteurs qui me connaissent : le ton que j'utilise ici n'est pas dans mes habitudes. Généralement, je ne refuse pas mon aide. Mais j'ai correspondu par mail avec ce monsieur pendant presque un an, pour l'aider à résoudre ses problèmes et il n'y arrive toujours pas. Et il revient périodiquement pour ensuite disparaître périodiquement. Son attitude n'est pas celle d'un modéliste dans la difficulté mais celle de quelqu'un qui aime nous faire perdre notre temps. Pour certaines personnes, c'est un loisir au même titre que le modélisme ferroviaire.  >:(

Inutile d'en rajouter : je lui ai dit ce qu'il doit faire pour que cela fonctionne et je me suis expliqué sur mes propos un peu secs. Pour moi, l'affaire est close !  :)

14
S'il y a des gens pour vouloir travailler avec des interrupteurs et des relais, grand bien leur fasse. D'ailleurs, je pense aussi à ces gens là puisqu'un article faisant le point sur les relais devrait paraître dans le bulletin de l'AFAN (pas le prochain mais le suivant).
Malgré cela, j'essaie depuis bientôt dix ans de montrer que les microcontrôleurs font bien mieux mais comme vous dites, il faut consacrer quelques heures à essayer de comprendre. Au début, les modélistes étaient réticents au numérique et maintenant, tout le monde ne jure que par lui ! L'utilisation des microcontrôleurs commence à émerger après 10 ans d'inertie. Pourtant, LOCODUINO a publié sur de nombreuses techniques appliquées au modélisme ferroviaire.
Je ne peux donc que me réjouir de voir des gens comme vous qui se lancent dans des techniques innovantes. Et je reste persuadé que vous arriverez au but car vous avez ce soupçon de curiosité et de pugnacité nécessaire pour réussir. Bonne continuation et on reste à votre disposition.


15
...
Ceci étant, ils me semblaient un peu complexes pour le presque débutant Processing que j'étais.  Aussi m'étais-je tourné vers l'éventualité d'une adaptation perso de la proposition de Christian (Ménage à trois).
...
jean-jacques
 

Bonjour Jean-Jacques,

Cela me fait plaisir de voir quelqu'un qui se tourne vers la modernité alors que les forums sont remplis de projets de TCO à l'ancienne, avec interrupteurs, potentiomètres et LED.

L'article "Ménage à trois" a été écrit pour faire la synthèse de ce que proposait Pierre dans ces articles (sans ce qu'il avait publié, mon article n'aurait sans doute jamais vu le jour). En effet, il y a assez peu de choses à faire pour commander un réseau analogique :
- savoir alimenter une voie de garage
- savoir changer le sens du mouvement sur une voie
- savoir commander une aiguille
Avec ces trois cas, on traite toutes les topologies de réseau. La nouveauté dans mon article était l'interface qui consiste à passer de Processing au réseau réel et la communication entre les deux.

J'ai donc appliqué ces principes à mon petit réseau et j'ai construit une interface : aujourd'hui, je commande mon réseau directement avec la souris de mon ordinateur. Le prochain Loco-Revue est supposé décrire tout cela afin d'inciter les modélistes à oublier l'électromécanique.

Je suis donc persuadé que vous arriverez au même résultat sur votre réseau, avec sans doute des améliorations auxquelles je n'ai pas pensé. Bonne continuation.

Christian

Pages: [1] 2 3 ... 20